Mysterious text console decay (was Re: WLAN with Linux SDIO: sneak preview)

Nelson Castillo nelsoneci at
Fri Nov 7 00:15:43 CET 2008

On Tue, Nov 4, 2008 at 8:11 PM, Andy Green <andy at> wrote:
> Hash: SHA1
> Somebody in the thread at some point said:
> | I'm starting a new thread for it, lest the WLAN thread gets too
> | confusing.
> |
> | I let the freshly booted device sit idle for many hours and nothing
> | happened. Then I booted again and let it sit some more but still got
> | the same. The next try was with a bit of WLAN activity. That brought
> | out the console problem (unfortunately, I forgot to check after how
> | much time):
> |
> | This is roughly what the LCM normally looks like:
> |
> |
> | And this is the decay (sorry about cutting off the left border):
> |
> |
> | You'd think someone had been playing Nethack ;-)
> |
> | As Andy predicted, pressing POWER brought back the screen in its
> | former glory.
> I think this can be OK... maybe the problem here is only that we are not
> taking down the backlight right now at that time.  It's OK if the video
> is insane or stopped then if it comes back OK when the backlight would
> (ie, on power button press).

Confirming here. (I disabled X in the rootfs).
I booted and after one hour or so the text console was OK.

so I run this:
killall pulseaudio
madplay sweet-dreams.mp3 --sample-rate=44100 --output=wave:- | aplay

And the text console decay appeared.

After pressing the power button the text console went back to normal.


PS: I noticed it before when I ran "aplay" for the first time.

More information about the openmoko-kernel mailing list