stable-tracking test image

"Marco Trevisan (Treviño)" mail at
Sat Nov 15 02:41:41 CET 2008

Werner Almesberger wrote:
> Andy Green wrote:
>> Yes not the flashing but the U-Boot environment is set up to only pull
>> 2MB into SDRAM, you can meddle it I believe.
> Yup. The following commands raise the limit to 3MB:
> setenv bootcmd setenv bootargs \${bootargs_base} \${mtdparts}\; nand read.e 0x32000000 kernel 0x300000\; bootm 0x32000000
> saveenv

Thanks I've used these instead of Qi. I can use the new kernel with
uBoot but I've noticed some issues:
 - The screensaver doesn't really turn off the screen; at the beginning
   it set the LCD light to a very low value then I see a white/black
   screen but always with the LCD on (if I used "xset s activate" I only
   get the brightness to a low value while I don't get any black/white

 - Once the power button stopeed working (so I wasn't able any more to
   suspend/resume or turning off my device)

 - On the latest boot I had no usb0 up and I wasn't able to connect via
   ssh. Using ifconfig/iwconfig from the FR terminal was impossible
   (they were hanging as soon as they were launched).

 - I wasn't able to get wifi working; using ifconfig/iwconfig/iwlist
   tools isn't always easy since they hangs so much.
   Has the new stack already been included? There was an HowTo by Werner
   to get it; should it be applied?

 - Once I tried to resume from suspend reconnecting the USB cable to the
   FR I got only the black resume-console-screen with the few resume
   lines written there. X wasn't restored and I wasn't able to recover
   it from ssh.

 - When I run Opendoom (without accelerometers) I get a white/green
   screen (similar to WSoD). As soon as I've killed the opendoom process
   Xglamo works before; however if I try to rotate the screen I get back
   the WSoD until I re-rotate it (this works if I don't run Opendoom

 - The touchscreen isn't so usable in some circumstances; for examples
   there are so many errors while writing with the illume keyboard (i.e.
   when dragging left [to delete] right [to space] up [to change layout]
   down [to send a return]). The same with numptyphysics, and using the
   illume configuration (while dragging there are unwanted clicks,
   generally made in a place quite far from the pressing point)
   Using the Tick's I've confirmed them too. The latest
   stable touchscreen implementation seems better than this one.

 - Qpe often crashes. I noticed it mostly resuming from a suspend, but
   it happened also in other circumstances. Launching it from SSH I get
   an error like:
      AtChat :  T : "▒"
      Mux :  *** mux setup timed out ***

I got also other strange things but I can't remember them now... Btw the
overall work seems pretty good and the phone seems more reponsive.
Of course I've to say that this is not to flash yet for daily usage :/

Treviño's World - Life and Linux

More information about the openmoko-kernel mailing list