stable-tracking test image

"Marco Trevisan (Treviño)" mail at
Sat Nov 15 04:15:44 CET 2008

Werner Almesberger wrote:
>>  - I wasn't able to get wifi working; using ifconfig/iwconfig/iwlist
>>    tools isn't always easy since they hangs so much.
> Hmm, what exactly is failing ? Does already listing the interfaces
> with iwconfig hang or fail to show eth0 ? Or are there specific
> configuration actions that start the trouble ?
> At least listing the interface always works for me, unless I have
> a completely trashed stack (i.e., during development).

Well, when I run ifconfig/iwconfig it slowly shows the first interface
(lo), then it hangs for some seconds and then shows the eth0 and usb0.

Running iwconfig eth0 I get an answer only after some seconds (sorry
I've not used 'time' at all).

The worst thing was that when I ran "iwlist eth0" I got no reply for
minutes and then I had to use Ctrl+C; looking at dmesg I had some
messages like "ar6000_ioctl_giwscan(): data length 0" (I don't remember
it correctly).

I'll try to check it again on next days...

Treviño's World - Life and Linux

More information about the openmoko-kernel mailing list