stable-tracking test image

Andy Green andy at
Sat Nov 15 11:17:38 CET 2008

Hash: SHA1

Somebody in the thread at some point said:

|> echo -n 1 > /sys/bus/spi/drivers/jbt6k74/spi2.0/reset
|> has no effect...
|>> Actual resume WSOD should be completely gone, the WSOD from blanking
|>> can still be around -- if you see it please cut and paste the
|>> results from this here
|> WSoD from blanking... One thing I notice is, that the screen does not
|> completly blank. It's still a little gray... And another thing I notice
|> is, that the screen is flickering when blanked.

The flickering is the LCM reset action, it would normally be hidden by
backlight off.  But accepting the backlight is up (I just found and
applied Werner's patch about that) it is all correct... if I understood
you right there is no WSOD from blanking?

| the same for me - also ended up with wsod again after suspend-resume

It's apparently really solved here.  This can be a clue about
differences in individual LCM found by Harald when he tried to fix the
blanking WSOD I suppose but it's not very satisfying.  Since the reset
action doesn't seem to do anything it's not clear if the Glamo is
issuing it for you (it definitely is here).

| echo 1 > /sys/bus/spi/drivers/jbt6k74/spi2.0/reset does nothing at the
| moment. when i tried before wsod, the screen would blink slightly, now

Right, it is resetting the asic in the LCM then.

| with wsod on it here is my bit:

These are the registers about Glamo GPIO, they are set as intended after
resume.  These were the problem before with Glamo unable to talk to LCM
after resume.

| 0050:  000f 111e ccc3 111e 000f 0001 000f 000f

Later I will try mine again with some freezer spray / hairdryer on the
Glamo and LCM.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-kernel mailing list