stable-tracking test image

Andy Green andy at
Sun Nov 16 23:58:11 CET 2008

Hash: SHA1

Somebody in the thread at some point said:

Thanks for the detailed report...

|  - The screensaver doesn't really turn off the screen; at the beginning
|    it set the LCD light to a very low value then I see a white/black
|    screen but always with the LCD on (if I used "xset s activate" I only
|    get the brightness to a low value while I don't get any black/white
|    screen).

This should have that problem solved:

|  - Once the power button stopeed working (so I wasn't able any more to
|    suspend/resume or turning off my device)

Hm well we will be changing to Balaji's new power stuff as soon as I can
compile it, it can change this.  Let us know if it happens again.

|  - On the latest boot I had no usb0 up and I wasn't able to connect via
|    ssh. Using ifconfig/iwconfig from the FR terminal was impossible
|    (they were hanging as soon as they were launched).

|  - I wasn't able to get wifi working; using ifconfig/iwconfig/iwlist
|    tools isn't always easy since they hangs so much.
|    Has the new stack already been included? There was an HowTo by Werner
|    to get it; should it be applied?

I think these can be to do with failure to do the S3C MMC config on the
first test kernel, hopefully you don't see it any more.

|  - Once I tried to resume from suspend reconnecting the USB cable to the
|    FR I got only the black resume-console-screen with the few resume
|    lines written there. X wasn't restored and I wasn't able to recover
|    it from ssh.

Did ps tell that X was dead?  Could chvt find it again?

|  - When I run Opendoom (without accelerometers) I get a white/green
|    screen (similar to WSoD). As soon as I've killed the opendoom process
|    Xglamo works before; however if I try to rotate the screen I get back
|    the WSoD until I re-rotate it (this works if I don't run Opendoom
|    before).

Hm well there can be breakage to exact video mode after resume, we don't
take care to restore it yet.  See if this acts the same before and after
resume to get a clue.

|  - The touchscreen isn't so usable in some circumstances; for examples
|    there are so many errors while writing with the illume keyboard (i.e.
|    when dragging left [to delete] right [to space] up [to change layout]
|    down [to send a return]). The same with numptyphysics, and using the
|    illume configuration (while dragging there are unwanted clicks,
|    generally made in a place quite far from the pressing point)
|    Using the Tick's I've confirmed them too. The latest
|    stable touchscreen implementation seems better than this one.

I have written to Tick to see if he has time to uplevel his patch, I did
look at upleveling it myself when he sent it, but it's different enough
I gave up on it.

|  - Qpe often crashes. I noticed it mostly resuming from a suspend, but
|    it happened also in other circumstances. Launching it from SSH I get
|    an error like:
|       AtChat :  T : "▒"
|       Mux :  *** mux setup timed out ***

No idea about it, AtChat and mux sound like UART to GSM issues?

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-kernel mailing list