stable-tracking test image

"Marco Trevisan (Treviño)" mail at
Mon Nov 17 14:44:59 CET 2008

Werner Almesberger wrote:
> "Marco Trevisan (Treviño)" wrote:
>> Well, when I run ifconfig/iwconfig it slowly shows the first interface
>> (lo), then it hangs for some seconds and then shows the eth0 and usb0.
> Hmm, interesting. I was about to write that no such problems were
> plaguing my systems, but just then, they did. With all the goodies,
> such as a six seconds delay before iwconfig was showing eth0, failure
> to associate, and lots of complaints about ar6000_ioctl_giwscan.
> On a second look, this device was running a development kernel using
> SDIO interrupts, which doesn't work reliably yet. With a kernel with
> an unbroken SDIO stack, I still haven't seen any of this.
> Do you get all those problems all the time ? And in particular, also
> right after booting ?

I've made a new test without using your testing rootfs-uImage for now (I
had few minutes to perform it :P) but using the latest Andy's image:

The first time I've loaded my FR with it, I logged in SSH just while the
phone was booting (Illume wasn't there yet) and I was able to run
ifconfig/iwconfig quickly (but I didn't test the iwlist scan). I waited
Illume to be booted and the above commands were still running fine; then
I've made the mistake of letting my phone suspend and just after
resuming I got the "hanging bug": ifconfig/iwconfig were slow to show
informations about eth0 and "iwlist eth0 scan" - after hanging for some
seconds - didn't show any result.

So, I booted again but disabling the auto-suspend this time. After my
phone loaded I ran again the same commands but this time I was able to
i[fw]config quickly, scanning and connecting using wpa_supplicant.

Finally I got associated with my AP. I wasn't able to get an IP from
DHCP but this always happened with this router (who knows why?! I've two
routers practically identical running both dd-wrt and in this one I
can't get an IP from DHCP); however manually setting my IP and the
routing I was able to connect.

Then I've suspended my device and... The hanging bug was back!
However this time, running "iwlist eth0 scan" I was able to see only the
network I was associated before hibernating (and that according to
iwconfig I was still associated to)... Also re-running wpa_supplicant
was practically impossible (it was hanging too).

So the problem seems to stay on the suspend/resume actions that
completely block my wlan.

Treviño's World - Life and Linux

More information about the openmoko-kernel mailing list