modules 2.6.28-rc3 (stable tracking) available?

Andy Green andy at
Mon Nov 17 15:05:17 CET 2008

Hash: SHA1

Somebody in the thread at some point said:
| Dear Andy,
| I'm using your qi-s3c2442-andy_7cc3d38184ae30bd.udfu and
| uImage-moredrivers-GTA02_stable-tracking_e7d89a2acb5da003-GTA02.bin from
| (both 16 nov 2008) and up to date
| FSO IV (opkg update/upgrade 15 nov 2008).
| With this qi and 2.6.28-rc3 kernel sound is working fine again, thanks!
| Two issues I encounter:
| o xrandr -o 1 makes the screen fade to bright white, forcing a shutdown
|   with the power button

That's a new one, the fading business is stopped pixel clock from Glamo
I think.  I'll try to reproduce.

| o farely often when I try to hit for example the character 'p' on the
|   keyboard (querty terminal), I activate space, alt or control

Hum, what's the physical relationship of those to "p" on this particular

| Both did never happen with 2.6.24 that came with FSO IV, but I'll flash
| that kernel again to be sure.
| Unfortunately GPRS doens't work due to the ppp being kernel modules. I
| tried to insmod -f the 2.6.24 modules but that failes with "invalid
| module format".
| Would you be able to make the modules available at
| or create a new kernel with ppp
| compiled in?

OK from now on I will provide a matching tarball for modules, unpack it
in / since it has the ./lib/modules/... and ./lib/firmware/... in the
tarball paths.

| I tried to boot
| to see if the recovery image contained modules, but booting failed with
| "bad CRC" or something. Likely due to it being 6.2MB?

Hum they should be two copies of the same kernel with one 4MB offset
from the other, it shouldn't make CRC issue.  But it's not what you
normally want anyway.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-kernel mailing list