modules 2.6.28-rc3 (stable tracking) available?

Andy Green andy at
Mon Nov 17 20:57:10 CET 2008

Hash: SHA1

Somebody in the thread at some point said:
| Dear Andy,
| Kernel uImage-moredrivers-GTA02_stable-tracking_d500794e07e71cc6.bin
| doesn't boot for me. It seems to freeze at the "Please wait booting"
| line and even requires a battery removal.
| I've flashed three times to be sure.
| I've downloaded the kernel again and done an md5sum to compare the first
| and second download, but they are the same.

I would guess that this is a module getting inserted and killing us somehow.

You can test this idea by doing a mv on /lib/modules temporarily so they
can't be found and try reboot into the crashing kernel.

| I've flashed kernel
| uImage-moredrivers-GTA02_stable-tracking_e7d89a2acb5da003-GTA02.bin
| again.
| Unfortunately this means the version of the modules is different from
| the kernel, and it seems insmod and modprobe don't support the -f
| switch. Loading of modules thus fails with "Invalid module format".

That should never happen with these builds... the kernel is looking down
a versioned /lib/modules/blah path, so a different kernel is unable to
see the wrong kernels' modules.  You should be able to see a matching
versioned path down /lib/modules/ for the kernel.

| Hm, the first boot the 'xrandr -o 1' command left me with the white
| screen. The second boot the 'xrand -o 1' command results in landscape as
| intended and both sketchbook and the keyboard react as expected ..
| I'll reboot a few times more and test.

Interesting, it just sounds like more evidence about flaky comms to the
LCM ASIC as seen with the blanking WSOD.

|> I wonder if it is the filtering not being cleared down on up though.
|> Apparently the first raw samples on down and up can be inaccurate I
|> think it was Tick mentioned it.
| Well, I can't immediately reproduce, but will test and report back when
| it happens.

I saw it here in the meanwhile with this illume-based image keyboard,
only sometimes tapping p gets me a z.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-kernel mailing list