mwester at dls.net
Tue Nov 18 16:54:12 CET 2008
[Can this be added to "stable" please? Thanks! Simple, short,
non-descriptive names seem to be the norm for the nodes beneath
/sys/classes/power_supply, so there seems to be no reason to do
differently for the GTA01, especially when doing so adds an
This patch changes the name of the gta01 battery driver to "bat"
in order to maintain compatability with the gta02 device.
Signed-off-by: Mike Westerhof <mwester at dls.net>
diff --git a/drivers/power/gta01_battery.c b/drivers/power/gta01_battery.c
index 873f8fd..fcbf991 100644
@@ -70,7 +70,7 @@ static int __init gta01_bat_init(void)
- bat_pdev = platform_device_register_simple("gta01-battery", 0, NULL, 0);
+ bat_pdev = platform_device_register_simple("bat", 0, NULL, 0);
More information about the openmoko-kernel