[PATCH] change-gta01-battery-driver-name.patch

Andy Green andy at openmoko.com
Wed Nov 19 23:29:26 CET 2008

Hash: SHA1

Somebody in the thread at some point said:
| Andy Green wrote:
|> Somebody in the thread at some point said:
|> |     in order to maintain compatability with the gta02 device.
|> | -    bat_pdev = platform_device_register_simple("gta01-battery", 0,
|> NULL, 0);
|> | +    bat_pdev = platform_device_register_simple("bat", 0, NULL, 0);
|> Is there any point we should call this "battery" on stable-tracking for
|> GTA01?  Android seems to have chosen that name for us but I am not sure
|> if this is the same namespace as it wants to call "battery".  We made
|> that change in stable-tracking already I think for GTA02.
| Oh.  Another one.
| Well, if the gta02 is going to change, there's no point in having the
| gta01 be different; that would only make the pain worse.  Let's make it
| match the gta02 on stable-tracking.

Sounds good.

| The new kernel version is really going to be quite the shock to
| user-space, I can see.

By and large the userspace impact is just /sys paths, it's not that bad.
~ Rootfs images still "work" in all the other aspects.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the openmoko-kernel mailing list