[PATCH 0/3] Qi booting control from rootfs

Andy Green andy at openmoko.com
Mon Nov 24 17:29:57 CET 2008

Hash: SHA1

Somebody in the thread at some point said:

| Ok, something is definately fishy around here - I reflashed the freshly
| downloaded qi ( s3c2442 is correct for the GTA2,  right? ) with a fresh
| dfu-util on another PC and get the same result - no more boots at all,
| only after 1h of toggling battery and/or cable NOR came up once more .

Hum.  Yes, 2442 is right for GTA02.

| What I did notice, that the same sound (like a one time click in the
| speaker) that occurs on battery insertion also can be heard on normal
| boots, be it NOR or NAND, whenever the power button is pressed - with
| the failed qi flash, I never heard that sound again on button presses!

It sounds like the GTA02 is sat there running something or crashed and
not handling the button.

| Also, a colleague had the same issue of no possibility to boot without
| having flashed u-boot, and it also only went away after changing
| batteries, charging and basically expecting to play around with what
| might be a brick for a good hour or longer...

Your colleague tried Qi and got this, or he got this without needing Qi?

|     So no doubt you experienced unhappy events but it's hard to see how Qi
|     is implicated... of course that's not much of an explanation either.
| Could it be there is a general issue with the power on bootup that is
| triggered by qi on my FR ? Any ideas what else to try ? I'll gladly
| supply you with any further information you might need.

Other folks have run Qi OK... I can imagine a bad block in NAND in
U-Boot partition might make trouble for Qi.  But it's hard to see how it
manages to make trouble for NOR flash startup.

The hour thing sounds like it could be to do with reaching NOPOWER state
in PMU by exhausting backup battery and that clears the problem.

I'll put together a GTA02 with a battery in later and try to reproduce
it more seriously.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org


More information about the openmoko-kernel mailing list