[PATCH 0/2] allow WLAN module to suspend/resume without reset

"Marco Trevisan (Treviño)" mail at 3v1n0.net
Fri Nov 28 16:31:44 CET 2008

Andy Green wrote:
> Somebody in the thread at some point said:
> | "Marco Trevisan (Trevi?o)" wrote:
> |> Strange... I neither touched wlan since I'd like to try a suspend/resume
> |> before. So its status was simply "idle".
> |>
> |> I compiled the kernel using the moredrivers config file and I had no
> |> modules at all in my rootfs...
> |
> | Hmm, I tried that and it works nicely for me. Of course, my system is
> | somewhat simple:
> Sounds good... Marco what exactly did "not resume from suspend" look
> like?  Does it start flashing AUX rapidly if you hit AUX key after that?
> ~ Is it possible the backlight never came up but it's otherwise OK?

No, I checked... Backlight was off and connecting the phone to the PC
didn't provide any line in my dmesg.

Btw I've tried again with the uImage provided by Werner (I didn't flash
the whole rootfs since I can't delete my flash nor my µSD actually :P),
however at first boot I've made many suspend-resume and they all worked

So I started my wifi tests; I connected to my AP using wpa_supplicant
and all was working well. So I tried to switch network (using wpa_cli,
so commanding directly wpa_supplicant) and I associated to it; however I
wasn't able to get an IP neither to ping it after that I configured the
my interface (IP) manually. I tried to go back to my first AP and I
associated to it, but, again no way to ping my router.
In this case scanning (both with wpa_cli scan and with iwlist eth0 scan)
 only returned my previous AP (also after an 'iwconfig eth0 essid off').

So I do a suspend/resume, and as expected, on resume I had a "fresh"
working wifi interface; I tried to redo the previous tasks but nothing
I also noticed that if, as a mistake, there are more instances of
wpa_supplicant running (I got two :P) and trying to control the eth0
interface, all the network related commands start hanging (from ping to
ifconfig going over iwconfig); killing all the wpa_supplicant instances
fixed the problem.

Finally I tried to suspend again but, as soon as the LCD backlight was
off I pressed again the power button, and now the phone didn't come up
again :(.
Could this simply due to the fact that I've asked the phone to wake-up
too early? :|

PS: This is not in theme, but the issue I had with qtopia-x11 are still
there. Qpe crashes after few seconds and so the phone can't work... :(

Treviño's World - Life and Linux

More information about the openmoko-kernel mailing list