Using the debug board on FreeRunner

Michael Shiloh michael at
Wed Oct 8 18:31:23 CEST 2008

Arigead wrote:
> Andy Green wrote:
>> Hash: SHA1
>> Somebody in the thread at some point said:
>> | Hello All,
>> |    Sorry this might not be the place for me but I was sent here, so 
>> here
>> | I am.
>> |
>> | I've got a FreeRunner that keeps locking up and needs to have its
>> | battery removed to get it back into a usable state. I'm an embedded C
>> | programmer of sorts but I've no real experience of the linux kernel. I
>> | use it in day to day work but the guts of it are a mystery. Anyhow I'd
>> | like to understand it a bit better, when I grow up, so I wanted to get
>> | the debug board V3 is available in, and find the reason 


> Thanks a million for the help Andy. Hopefully the next time you hear 
> from me I'll have something constructive to offer. Don't hold your 
> breadth though.

Arigead, it's very likely that your phone locking up can be solved by 
installing the latest u-boot/kernel/rootfs. You don't need the debug 
board for this.

Click on the "distributions" button in the wiki navigation box. You 
might wish to start with Qtopia and then experiment with the others 
after you've verified that the lockups are solved. Many of us enjoy FDOM.


More information about the openmoko-kernel mailing list