[UPSTREAM - RFC] pcf50633_use_regulator_api.patch
werner at openmoko.org
Thu Oct 9 06:07:10 CEST 2008
Balaji Rao wrote:
> Mark had expressed his feeling that as a subsystem maintainer he would
> prefer that things are separated.
I think his reason is probably that, if there are any API changes or
if he wants to look for how people use the API, he has all the code
in question in one place, not scattered all over the tree, making it
easier for him to find things, and also for others to see what his
changes are doing. (I.e., "he updated the users of his API" vs. "he
made changes seemingly all over the kernel".)
Properly hiding "internal" symbols may a bit tricky, I agree. On the
other hand, it seems pretty unlikely that anyone else would invade
the pcf50633_* namespace, or feel invaded by it.
There is precedent for this, e.g.,
drivers/mmc/host/tmio_mmc.c uses tmio_io* defined in
include/linux/mfd/tmio.h and shared with
> I'm still not sure. It's highly debatable. I'd be happy be some more
> discussion so that we come to a uniform conclusion.
I think splitting the drivers is the modern way of doing it. It's
biased towards the subsystem maintainer(s)/reviewer(s) instead of
towards the driver author(s), but I guess you can't have your cake
and eat it too in this case ...
More information about the openmoko-kernel