[Stable] Unable to compile GTA02 kernel without CONFIG_MACH_NEO1973_GTA01 set

Nelson Castillo nelsoneci at gmail.com
Thu Oct 9 23:28:48 CEST 2008

On Thu, Oct 9, 2008 at 3:22 PM, Andy Green <andy at openmoko.com> wrote:
> Hash: SHA1
> Somebody in the thread at some point said:
> | Hello,
> |
> | I tried to compile the current stable kernel
> | (a2ef813d2f439a3e9f377d33a2e5baad098afb7e)
> | without setting CONFIG_MACH_NEO1973_GTA01. The compilation failed with
> | the attached
> | error. Setting CONFIG_MACH_NEO1973_GTA01=y (and CONFIG_CPU_S3C2410=y)
> solved
> | the problem
> It seems some other folks are interested to take care about making sure
> we are clean for config variations, I'll leave this to them.


I already thought about it and I will write a Python program really
soon. I would like to start with something that is not that smart but
that can be very useful. That is, a script that allows you to try all
the kernel configuration files that live in a specific directory. For
each configuration the result of the program will be: the name of the
config. file, status of the build and the name of a file with all the
compilation messages. The status can be either OK, FAILED, or TIMEOUT.
Timeout means that some time elapsed with no compiler activity and
with no built kernel (Actuallly this should only happen because of a
bug in this program or in GCC).

I think this is very simple and useful. Then I'd like to ask for some
feedback and add the automatic tests since we have to think about some
issues that might come out generating variations of existing
configurations... I mean, I'm sure I'll think more about this problem
while I build the basic program I proposed.



More information about the openmoko-kernel mailing list