stable-tracking unification update

Andy Green andy at
Sat Oct 25 06:26:43 CEST 2008

Hash: SHA1

Hi -

I have rebased stable-tracking in git on the s3c6410 work tree, this has
the great result that we have a single unified tree going on that can be
built for both TLA01 (future unnamed 6410 product) and GTA01/02.  I'll
keep rebasing it as new stuff comes in and Ben in turn will be rebasing
it on upstream.

There's a TLA01 config now in ./arch/arm/configs/tla01_defconfig which
creates a working kernel on 6410 SMDK and it builds a mostly-working
kernel for GTA02 just fine too with
./arch/arm/configs/gta02-moredrivers-defconfig.  So this is going to
make adding drivers, especially shared ones, into TLA01 kernel much
easier now.

In addition, I dumped the andy-tracking patchset into stable-tracking.
There might be some small breakage because andy-tracking had balaji's
patches on top of stable-tracking, but except for some small mystery
about the recent i2c device api update breaking in mach_gta02.c (worked
around), it seems OK at first glance.

There were many updates to mokopatches and stable-tracking patchsets
needed for the rebase, for example the sound SoC stuff had changed how
you pass in the I2C stuff, I updated the patches to cope with it (anyway
the device is recognized).

It now has stuff like the long-pending median touchscreen filtering
patch in as well.

I noticed someone has made a different bq27000 (smart battery chip)
driver and got it upstream already, that'll make fun.

I plan to do more work now on gta02 side with this tree, we can expect a
lot of breakage from these mass changes at both ends of the tree...
known ones right now:

~ - wlan power patch is in right now so WLAN doesn't come up (the stack
isn't capable of recognizing "insertion" of the WLAN device when we
power it)

~ - Motion sensors comms is broken

~ - I was unable to get Harald's second NAND patch to apply due to
changes in the upstream code, the whole section patched there is gone
somewhere else.

~ - I tried suspend with Qi and resume is completely broken right now,
however it has been decent on andy-tracking so I will study this the
rest of today.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-kernel mailing list