stable-tracking unification update

Andy Green andy at
Sat Oct 25 10:10:01 CEST 2008

Hash: SHA1

Somebody in the thread at some point said:

|> These are actually the workarounds I mentioned about I2C and PMU probing
|> not working... I first tried the code same as after this patch, PMU
|> probe was never called.  Only when I commented out the newish
|> i2c_register_board_info and went back to explicitly registering the pmu
|> device the old way could I get the PMU to be seen on boot.
|> Did it work for you?  I didn't find out what the real problem is just
|> worked around it and moved on.
| I didn't try it by hoped that it would work. :) I'm building it now..
| A quick check - Did you notice that I've removed pcf50633 from
| and added the wm8753 instead ? I don't understand why it would still
| with the PMU..

I also mentioned that the uplevelled mokopatches dealt with the new way
of passing i2c information into the wm8753 driver... it handles that
action now.  Maybe that's what trashes up the PMU registration / bus
attach stuff for PMU.

Anyway that is why I removed wm8753 i2c registration from mach-gta02.c,
it's now done in the gta02 wm8753 driver.

- -Andy
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the openmoko-kernel mailing list