[PATCH] Correct platform s3c-ohci device name, makes bluetooth work

Paul Fertser fercerpav at gmail.com
Tue Apr 7 22:51:35 CEST 2009


Not sure what is the correct naming scheme and if MODULE_ALIAS in
drivers/usb/host/ohci-s3c2410.c is needed at all (if yes, probably it
should be modified too).
---
 arch/arm/plat-s3c/dev-usb.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/arch/arm/plat-s3c/dev-usb.c b/arch/arm/plat-s3c/dev-usb.c
index 2ee85ab..721ff18 100644
--- a/arch/arm/plat-s3c/dev-usb.c
+++ b/arch/arm/plat-s3c/dev-usb.c
@@ -37,7 +37,7 @@ static struct resource s3c_usb_resource[] = {
 static u64 s3c_device_usb_dmamask = 0xffffffffUL;
 
 struct platform_device s3c_device_usb = {
-	.name		  = "s3c2410-ohci",
+	.name		  = "s3c-ohci",
 	.id		  = -1,
 	.num_resources	  = ARRAY_SIZE(s3c_usb_resource),
 	.resource	  = s3c_usb_resource,
-- 
1.5.2.2




More information about the openmoko-kernel mailing list