[M800] Touchscreen filters are not working

Nelson Castillo arhuaco at freaks-unidos.net
Wed Apr 8 18:16:33 CEST 2009

>> Are you getting a lot of noise with no filters? With median + mean?
> With no filters enabled we always have the situation, that the reported
> events are in the top left corner and they are reported with no pressure
> on the ts. How could I test it to get more information about the noise?
> Is there any test app?

Oh! Are you using tslib? I think you need this:

module_raw input
module pthres pmin=1
module linear

And you need to calibrate the TS. Perhaps this is the problem?

# cat /etc/pointercal
557 38667 -4654632 -51172 121 46965312 65536

This test application should help:


>>> I hope someone who is familiar with the new touchscreen filters can help us.
>> Where's the code? (Just to see what it looks like).
> Sorry I forgot to add the link. Here it is:
> http://git.gnufiish.org/?p=gnufiish.git;a=blob;f=arch/arm/mach-s3c2440/mach-glofiish.c;h=bdf4d1e2d235a47ddc0c282d33fd7df1fa94036a;hb=HEAD

I noticed you're using an old version of the code. The configuration
was simplified. Latest versions:


(this was the last change / dirty patches with style fixes included...).

You might want to check mach-gta02.c also. But again, I think you have
to make the driver work before using the filters.

> Will try and report.

I didn't understand the report you sent. I think you could listen to
the events and show them as they are reported.

More information about the openmoko-kernel mailing list