Openmoko Bug #2217: Noise screen of death: Freerunner looses SDIO connection

Openmoko Public Trac bugs at
Sat Feb 7 23:37:30 CET 2009

#2217: Noise screen of death: Freerunner looses SDIO connection
 Reporter:  xbaldauf         |          Owner:  openmoko-kernel
     Type:  defect           |         Status:  new            
 Priority:  normal           |      Milestone:                 
Component:  System Software  |        Version:                 
 Severity:  major            |       Keywords:                 
 Haspatch:  0                |      Blockedby:                 
Estimated:                   |    Patchreview:                 
 Blocking:                   |   Reproducible:                 

Comment(by xbaldauf):

 I've been running;a=commit;h=9029dff1f370018665a6e2999632a34fd0518f4d
 ( Thu, 5 Feb 2009 17:01:56 +0000 (17:01 +0000) ) with kernel parameter
 "glamo3362.slow_memory=1" now for about 24 hours and I have experienced 3
 crashes|lockups (all during screen blank, so I do not know the cause or
 whether these had to do something to do with this bug), but no crash of
 the type "Noise screen of death:". Judging from the frequency of the bug
 before, I think your workaround works. :-)
 I'll try to change the setting from time to time to try out the other
 clock and wait state settings to find an optimum setting.

 I did not notice any speed difference, is there any howto or document
 describing which speed should differ with respect to the waitstate number
 and frequency used? Maybe there is even a kind of benchmark program? (E.g.
 Is 50 MHz, 0 waitstates faster than 90 MHz, 1 waitstate?)

Ticket URL: <> <>
openmoko trac

More information about the openmoko-kernel mailing list