[PATCH] fix-pm-gsm-disable-serial-drive-when-off.patch

Paul Fertser fercerpav at gmail.com
Sun Feb 22 15:52:53 CET 2009

Werner Almesberger <werner at openmoko.org> writes:
> Andy Green wrote:
>> Since several people worked on this area before, and maybe the
>> assertion of GSM OFF is different (it's OFF from bootloader though)
>> or maybe something else gets broken, I send the patch for comment
>> before applying it.
> Thanks ! At first glance, it looks good. I'll give it a closer look
> tomorrow.
>> +	s3c2410_gpio_cfgpin(S3C2410_GPH1, S3C2410_GPH1_OUTP);
>> +	msleep(1000);
>> +	s3c2410_gpio_cfgpin(S3C2410_GPH1, S3C2410_GPH1_nRTS0);
> Do we really have to wait a whole second ? Perhaps Dieter can help
> us with this question.

I flashed moko10 and did some experimenting before i wrote that
line. 1000ms looks incorrect, for sure, but the reason for that is
simple: just before that i assert and de-assert push-button and 500ms
for that is always enough (i decided to be on the safe side and not
tried to lower it further). If not for the bug in firmware, that'd be
all is needed to be done inside the driver. But if we want to
workaround that nasty issue, we have to wait a bit for the modem to
boot. I decided to consolidate additional delay needed in this
workaround line, so the workaround can be easily dropped altogether,
minimizing the time needed for power_on.

So, that's not a time needed for the calypso to "feel" the line,
that's mostly the time needed for it to boot. 500ms was not enough.

Be free, use free (http://www.gnu.org/philosophy/free-sw.html) software!
mailto:fercerpav at gmail.com

More information about the openmoko-kernel mailing list