[PATCH] consistent defconfig naming ?

Werner Almesberger werner at openmoko.org
Sat Jan 31 12:14:02 CET 2009

The naming of our defconfigs is currently inconsistent: three of them
end in -defconfig and use - also as an internal separator. One sends
in _defconfig but uses - as internal separator, and one ends in
_defconfig without needing an internal separator so far.

All the other defconfigs end in _defconfig. 21 use _ also as
internal separator and 5 use -.

So most of our names differ from the style everyone else is following
and there's also inconsistency among our names.

The git patch below renames them to the dominant all _ scheme.

There's always some latent undesirability for such cleanup patches
that may break some habits or scripts. So if there are strong
sentiments against doing this now, I won't push the issue. But in
general, the sooner one gets those little things done, the better.

Signed-off-by: Werner Almesberger <werner at openmoko.org>


diff --git a/arch/arm/configs/gta01-moredrivers-defconfig b/arch/arm/configs/gta01_moredrivers_defconfig
similarity index 100%
rename from arch/arm/configs/gta01-moredrivers-defconfig
rename to arch/arm/configs/gta01_moredrivers_defconfig
diff --git a/arch/arm/configs/gta02-micro_defconfig b/arch/arm/configs/gta02_micro_defconfig
similarity index 100%
rename from arch/arm/configs/gta02-micro_defconfig
rename to arch/arm/configs/gta02_micro_defconfig
diff --git a/arch/arm/configs/gta02-moredrivers-defconfig b/arch/arm/configs/gta02_moredrivers_defconfig
similarity index 100%
rename from arch/arm/configs/gta02-moredrivers-defconfig
rename to arch/arm/configs/gta02_moredrivers_defconfig
diff --git a/arch/arm/configs/gta02-packaging-defconfig b/arch/arm/configs/gta02_packaging_defconfig
similarity index 100%
rename from arch/arm/configs/gta02-packaging-defconfig
rename to arch/arm/configs/gta02_packaging_defconfig

More information about the openmoko-kernel mailing list