GTA01Bv4 Uboot problem

Marc Verwerft marc.js.verwerft at
Mon Jul 20 15:42:45 CEST 2009


Need some advice here. A couple of days ago I've updated the GSM
firmware to Moko11. After that I wanted to flash a newer version of
the distro. Unfortunatelly, it didn't boot though. So I updated uboot and got a
lot further (but still no full boot). Then I Itried another version.
Kernel flashing went fine
but each time I try the rootfs, the uboot process stops somewhere with
an error, sometimes -75, sometimes -84). I tried working out what was
According to
dfu-util should list 5 partitions while I only see 2:

marc at marc-laptop:~$ dfu-util --list
dfu-util - (C) 2007-2008 by OpenMoko Inc.
This program is Free Software and has ABSOLUTELY NO WARRANTY

Found Runtime: [0x1668:0x2441] devnum=2, cfg=0, intf=2, alt=0, name="UNDEFINED"
Found Runtime: [0x1457:0x5119] devnum=3, cfg=0, intf=2, alt=0,
name="USB Device Firmware Upgrade"

I think I must have accidentily overwritten the partition table.

I don't know if I can trust this 'nand bad' command but this is the output:

marc at marc-laptop:~$ cu -l /dev/ttyACM0

GTA01Bv4 # nand bad

Device 0 bad blocks:
GTA01Bv4 # ~.

Is there an way to fix this?



More information about the openmoko-kernel mailing list