WSOD on device

Nicolas Dufresne nicolas.dufresne at
Sat Mar 21 15:06:53 CET 2009

The reset part I've cut off, was a patch introduce by Andy to try and
solve a sticky WSOD issue (#1841). This has never worked for anybody.
According to the part of spec provided by Joerg, it is not required to
reset the chip in order to wake from deep standby.

In 2.6.24, the solution was not to go in standby, which seems to work
but uses more energy. For sure this solution will fix your problem, but
I'm surprise I can't reproduce it on my side. Also, if I write code to
provoque a WSOD in 2.6.29, I can always recover by putting my device
into sleep and resuming it. I haven't explained yet, but it might be
related to the changes made in the power controller driver.

In bug #1841, Joerg has proposed adding some safety around minimum sleep
required to switch between states. He also mentioned something about
missing sleep after sleep-out transition. I had completely forgot about
it so far, it is something we should have a look at.


Le samedi 21 mars 2009 à 09:43 +0100, Michael Trimarchi a écrit :
> Nicolas Dufresne wrote:
> > Le vendredi 20 mars 2009 à 18:32 +0100, Michael Trimarchi a écrit :
> >   
> >> You cut this code too
> >>     
> >
> > Do you mean that adding back the reset fix your issue? More details on
> > what you tried, and how you get the WSOD would be usefull. I'll have a
> > look too since other changes (a new LCM) has been added since this
> > patch.
> >
> >
> >   
> I don't see any comment from you about this cut-off. It just a question.
> For now I revert the entire patch and my freerunner run. On monday I
> go step by step to understand what happen exaclly. I want to know if
> It is an invalid state or just an invalid command sequence
> Michael

More information about the openmoko-kernel mailing list