openocd: "timed out while waiting for target halted"

Timo Juhani Lindfors timo.lindfors at
Thu May 7 11:38:04 CEST 2009


with the new xf86-video-glamo driver I sometimes see a bug where
issuing "chvt 1" causes WSOD. I started to investigate this with the
debug board but noticed that in this state I can't even stop the cpu:

> halt
waiting for target halted...
timed out while waiting for target halted

Any idea what's going on? I have openocd 0.0+r655-1.1 from debian
stable with debug board V2 (1457:5118) and GTA02V5. libftdi1 has
version 0.13-2 and the openocd.cfg has

telnet_port 4444
gdb_port 1235
interface ft2232
jtag_speed 0
ft2232_vid_pid 0x1457 0x5118
ft2232_layout "jtagkey"
reset_config trst_and_srst
jtag_device 4 0x1 0xf 0xe
daemon_startup attach
target arm920t little reset_run 0 arm920t
working_area 0 0x200000 0x4000 backup
run_and_halt_time 0 5000
ft2232_device_desc "Debug Board for Neo1973"

When I have not said "chvt 1" I can halt the CPU just fine:

> halt
waiting for target halted...
target state: halted
target halted in ARM state due to debug request, current mode: Supervisor
cpsr: 0x80000093 pc: 0xc002ff9c
MMU: enabled, D-Cache: enabled, I-Cache: enabled
> resume

I googled around with "timed out while waiting for target halted"
finds [1] that suggests my to use rev 953. Debian unstable had 1409 so
I tried it:

Open On-Chip Debugger 1.0 (2009-03-12-01:10) svn:r1409

BUGS? Read /usr/share/doc/openocd/BUGS

$URL: $
jtag_speed: 0
OLD SYNTAX: DEPRECATED - translating to new syntax
jtag newtap CHIP TAP -irlen 4 -ircapture 0x1 -irvalue 0xf
Example: STM32 has 2 taps, the cortexM3(len4) + boundryscan(len5)
jtag newtap stm32 cortexm3  ....., thus creating the tap: "stm32.cortexm3"
jtag newtap stm32 boundry  ....., and the tap: "stm32.boundery"
And then refer to the taps by the dotted name.
invalid command name "daemon_startup_attach"

I commented out "daemon_startup attach" but then it complains about

Runtime error, file "openocd.cfg", line 10:
    bad option "arm920t": must be one of count, create, current, names, number, or types

Has somebody worked out a working configuration file for never openocd versions?

best regards,
Timo Lindfors


More information about the openmoko-kernel mailing list