ARM FCSE - random programs segfaults

Martix at
Sun Mar 28 03:36:01 CEST 2010

> Gilles Chanteperdrix wrote:
>> We need a common reference, could you run your test on a vanilla 2.6.30
>> kernel with the adeos I-pipe patch (simply, only enable FCSE):

I tried to compile vanilla 2.6.30 kernel both with and without FCSE
enabled, but device hangs up when starting the kernel. Probably
because the Neo FreeRunner is not supported in vanilla 2.6.30. I tried
apply your adeos-ipipe patch against 2.6.31 and 2.6.32, but of course
I got multiple errors.

> In fact, I would be more interested if you could run this modified LTP:

Otherwise, I got error while crosscompiling your LTP:

make[4]: Entering directory
/usr/local/openmoko/arm/bin/arm-angstrom-linux-gnueabi-gcc -Wall
-I../../include -g -Wall -I../../../../include -Wall    signalfd01.c
-L../../../../lib -lltp -o signalfd01
signalfd01.c:58:26: error: sys/signalfd.h: No such file or directory
make[4]: *** [signalfd01] Error 1
make[4]: Leaving directory

> on your target running the vanilla 2.6.30 kernel with Adeos patch, with
> and without best-effort FCSE enabled. And send me the logs.
> We need to know if your processor run as well with FCSE as the
> processors I have tested or if there is a bug in the FCSE patch. I would
> tend to think that it is a bug in the FCSE patch, if you can make run
> the system well after restarting it several times (if your processor had
> issues with FCSE, it would crash all the time).
> --
>                                            Gilles.

More information about the openmoko-kernel mailing list