Openmoko Bug #2349: Too high power consumption in 2.6.32

Openmoko Public Trac bugs at
Thu Sep 16 11:53:19 CEST 2010

#2349: Too high power consumption in 2.6.32
 Reporter:  Q-Master  |          Owner:  openmoko-kernel
     Type:  defect    |         Status:  new            
 Priority:  high      |      Milestone:                 
Component:  kernel    |        Version:                 
 Severity:  major     |       Keywords:                 
 Haspatch:  0         |      Blockedby:                 
Estimated:            |    Patchreview:                 
 Blocking:            |   Reproducible:  always         

Comment(by Treviño):

 Replying to [comment:18 psonek]:
 > Please make sure that your problems are relevant to this bug and are
 caused by the attached patch. Try compiling without the patch and report
 if your problems disappeared.

 Of course they are... I'm using the SHR 2.6.32 kernel as base, plus I've
 added the attached patch [1] (which is basically the one posted by gena2x
 ported to the older kernel). Without that I've no issues; using it

 > I am running 2.6.34 with attached patch and i dont have your problems.
 Please also tell us which sources are you using, how you compile and which
 config are you using. At leasr for your third problem there is already
 > do you have it in your sources?

 Yes, of course since that patch is included in the SHR OE configuration...

 Replying to [comment:19 gena2x]:
 > Please, do as Radek suggests, your kernel issues unlikely to be related
 to this patch. And also - this is _not_ workaround. Why do you think it

 As I've said, my kernel without this patch works... However, I thought it
 was a workaround since you said that the phone should have had turned off
 all his peripherals also before of this setting change...


Ticket URL: <> <>
openmoko trac

More information about the openmoko-kernel mailing list