[Debian] 2.6.37 kernel available (and about the touch screen X driver problem)

Timo Jyrinki timo.jyrinki at gmail.com
Fri Apr 29 06:42:40 CEST 2011


During the night my native Neo compilation of 2.6.37 kernel succeeded,
and is now uploaded to Debian's pkg-fso repository [1]. The sources
are in git [2] as well, although this was again a complete rebase.

[1] http://pkg-fso.alioth.debian.org/debian/pool/main/l/linux-2.6-qtmoko/
[2] http://git.debian.org/?p=pkg-fso/linux-2.6-openmoko.git

The new package name reflects the fact that the upstream is QtMoko's
git repository, which adopted our Debian packaging as well recently.

There was a hint reportedly on IRC that the recent touch screen
problem with Debian unstable would be caused by
xserver-xorg-input-tslib being compiled against more recent kernel
headers. Alas, it seems that touch screen even on this 2.6.37 kernel
didn't start to work right away. Maybe with 2.6.39/2.6.40 then, which
also have more upstreamed Openmoko drivers once again (thanks to those
people). Anyway, it's now available for experimentation, and if you
are staying more with Debian 6.0 like I do on my daily phone, it might
be actually a great kernel to use - I haven't tested it yet.

Below is the changelog including the previous Debian version (QtMoko
took the packaging of one before it) and QtMoko:

linux-2.6-qtmoko (20110412.git425779c72-1) pkg-fso; urgency=low

  * Rebase on qtmoko-2.6.37-v35 branch of QtMoko
  - Packaging of which was based on 20101108.git1508bbb5-1
  * Add back requested configuration switches:
  * Add patches that still apply:
  - 0007-Make-PTRACE_SINGLESTEP-work-with-user-helpers.patch
  - 0008-Do-not-print-debug-messages-on-every-touchscreen-eve.patch
  * Adjust Maintainer and Uploaders

 -- Timo Jyrinki <timo at debian.org>  Thu, 28 Apr 2011 18:22:36 +0300

linux-2.6-openmoko (20101212.git049b71de-1) pkg-fso; urgency=low

  * Merge from qtmoko-v31
  - Kernel
  - Integrated GPS suspend patch, resume reason patch
  - Dumb battery support
  * Disable sysrq, unneeded
  * Add configuration from wishlists:
  - NFSv4
  - XATTR for EXT*
  * Remove 2.6.29 era patches and others that don't apply anymore

 -- Timo Jyrinki <timo at debian.org>  Wed, 15 Dec 2010 19:32:13 +0200

linux-2.6-qtmoko (v34-1) unstable; urgency=low

  * Update sources to 2.6.37 from openmoko git
  * Port qtmoko patches from 2.6.34
  * QtMoko config

 -- Radek Polak <psonek2 at seznam.cz>  Wed, 23 Mar 2011 14:33:56 +0100


More information about the openmoko-kernel mailing list