2.6.37 (qtmoko-v32.1 test report)

Timo Juhani Lindfors timo.lindfors at iki.fi
Tue Jan 18 18:13:12 CET 2011

Lars-Peter Clausen <lars at metafoo.de> writes:
> Ah, ok you are still using 2.6.29.

I'm testing various different kernels and I'd like to keep omhacks
compatible with as many of them as reasonably possible. I'm still
using 2.6.29 as my "stable" boot menu entry followed by 2.6.34 as
"testing" and 2.6.37 as "experimental".

> The path I posted only works with the 2.6.3x kernels.

Sorry, I think I missed this patch when I read your mail for the first
time and now I can't find it anymore. I clicked through the emails at


but can't find it. Which mail did I miss?

> So the "resolution" sysfs attribute expects either qvga or vga and
> the the state sysfs attribute expects normal or normal-qvga.

Can you recommend some strategy for supporting both 2.6.29 and 2.6.3x
in omhacks? The first idea is the following pseudocode:

def rotate(idx):
 if read("resolution") in ["vga", "qvga"]:
 if new_api:
  write("resolution", ["vga", "qvga"][idx])
  write("resolution", ["normal", "normal-qvga"][idx])

More information about the openmoko-kernel mailing list