SSH session

e hanks maskvp at
Sun Aug 3 03:39:06 CEST 2008

I was having a problem with not being able to re-connect to my FR after
unplugging the usb. I'd have to reboot my lappy in order to ssh to the FR. I
saw the fix listed on the usb networking page:

Since I use Ubuntu I changed the order of the code as instructed despite the
comments that it doesn't work. It worked for me.

However, I was checking out the suggested code for /etc/network/interfaces
and it is different from what was posted several weeks ago. I had edited the
original /etc/network/interfaces to this:
auto lo
iface lo inet loopback

auto usb0
iface usb0 inet static
   up iptables -A POSTROUTING -t nat -j MASQUERADE -s &
   up echo 1 > /proc/sys/net/ipv4/ip_forward &
   up iptables -P FORWARD ACCEPT &
   down iptables -D POSTROUTING -t nat -j MASQUERADE -s &

iface eth0 inet dhcp

This has worked fine so far AFAIK.

However, the current suggested code for /etc/network/interfaces is:

 allow-hotplug usb0
 iface usb0 inet static
        post-up iptables -A POSTROUTING -t nat -j MASQUERADE -s
        post-up echo 1 > /proc/sys/net/ipv4/ip_forward
        post-up iptables -P FORWARD ACCEPT
        pre-down iptables -D POSTROUTING -t nat -j MASQUERADE -s


What is the difference between 'auto usb0' and 'allow-hotplug usb0'?
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the support mailing list