Worrisome output from "opkg -test update" in 2007.2

Olivier Berger oberger at ouvaton.org
Sun Aug 3 18:46:16 CEST 2008

"Dale Schumacher" <dale.schumacher at gmail.com> writes:

> On Sun, Aug 3, 2008 at 6:35 AM, Jeffrey Ratcliffe
> <jeffrey.ratcliffe at gmail.com> wrote:
>> 2008/8/2 Olivier Berger <oberger at ouvaton.org>:
>>> Doing an opkg remove gtk+-fastscaling and opkg upgrade gtk+ solved the
>>> issue, I think. YMMV though.
>> I needed
>> opkg remove -force-depends gtk+-fastscaling
>> but otherwise this sorted out the error messages.
> Thank you.  I really appreciate the work-around for gtk+.
> However I think this represents an example of a deeper issue.  How
> many -force-depends, -nodeps or remove foo / install bar are we
> expecting new users to navigate when trying to upgrade from their
> factory configurations?  Is it not possible to get the package
> dependencies properly defined so that opkg will "just work"?  

I suppose you'd like to check
https://docs.openmoko.org/trac/ticket/1650 which seems to explain
where the issue comes from, AFAICT... maybe this will enlighten you a
bit more ?

Best regards,
Olivier BERGER 
(OpenPGP: 1024D/B4C5F37F)

More information about the support mailing list