Unnecessary rant - Was: Re: USB networking in Ubuntu

Zack Mollusc zmollusc at blueyonder.co.uk
Wed Aug 6 15:25:12 CEST 2008

Richard Cooke wrote:
> It is a shame you have alienated the support staff on this list since I
> suspect I am not on my own in having difficulty getting USB networking
> between the freerunner and Ubuntu up and running.
> I am something of a Linux noob and a complete openmoko beginner and perhaps
> as such I was a little rash in taking this thing on. I am running Ubuntu
> 8.04 64 bit on an AMD64 box.
> I have spent a couple of days trawling google trying to get this going and
> late last week was successful enough to be able to upgrade my device. I
> thought at the time that maybe I should never power down my box again, but
> power it down I did.
> The problem I now have is that I am unable to get usb0 recognized as an
> interface by ifconfig.
> The command:
> ifconfig usb0
> results in
> SIOCSIFADDR: No such device
> usb0: ERROR while getting interface flags: No such device
> I have tried modprobing usbnet and cdc_ether but the problem remains.
> Help from any quarter would be much appreciated as I am at my wits' end.
> Thanks,
> Richard

Hello, i am also a noob running umbongo (i am on 32bit 8.04) and i had a similar problem.
I broke the whole thing on the fr and no longer had a gui, I flashed the root filesystem
(Openmoko-Freerunner-20080424-om-gta02.rootfs.jffs2)and seemed to lose
usb connectivity, with similar host response, and after some vain faffing
about with the host machine(i thought the usb port had become confused)
, I flashed the kernel (uImage-2.6.24+git20080424-om-gta02.bin) and that
seemed to fix it for me. Obviously I had to install the apps again.
Good luck.

More information about the support mailing list