qtopia image at /media/card directory

Alex Kavanagh alex at ajkavanagh.co.uk
Wed Aug 6 18:31:47 CEST 2008

Hi Lorn

Lorn Potter wrote, On 05/08/08 19:20:
> Alex Kavanagh wrote:
>> Hi
>> I've been running the qtopia image for a few days and I'd like to dual
>> boot it with the ASU or FSO image just to keep an eye on what is
>> happening with them.
>> Thus I have the qtopia in the main flash, and I'd like to put the ASU or
>> FSO image into the SD card.
>> However, I ran into a problem.  the SD card is mounted at /meda/card
>> (it's the original card that came with the phone), and there is a
>> qtopia_db.sqlite file on it.
>> And sure enough the qpe process has open file handles on it and so is
>> clearly using it.
>> Does anyone know where the config option is for moving this file off
>> /media/card?  I can't find it anywhere after grepping the whole device
>> for /media/card, card, /media, etc.
> Look in ~/Settings/Trolltech/Storage.conf
> (or /opt/Qtopia/etc/default/Trolltech.Storage.conf)
> In the [MountPoint0] section, change
> ContentDatabase = 1
> to ContentDatabase = 0
> Does this help?
It certainly pointed me in the right direction!  In the end I commented
out the entry for "Mounts" in
/opt/Qtopia/etc/default/Trolltech/Storage.conf and it worked ok.

If I just set the ContentDatabase = 0 and then umounted the card the qpe
application started throwing up 'sync' problem messages.

Thanks very much for your help.

More information about the support mailing list