Is anyone working on Ruby 1.9 for GTA01/02 ?

Jim Morris ml at
Sun Aug 10 01:49:25 CEST 2008

Michael 'Mickey' Lauer wrote:
> Am Freitag 08 August 2008 20:08:38 schrieb sparky mat:
>> On Fri, Aug 8, 2008 at 11:24 PM, Jim Morris <ml at> wrote:
>>> sparky mat wrote:
>>>> I was wondering if anyone was working on porting Ruby 1.9(.0-3) for
>>>> GTA01/02.
>>> Now I have mokomakefile working, I was going to port 1,8,6 although 1.8.5
>>> is available as an ipkg
>>> but is missing essential libraries.
>> I just felt that 1.9 would make more sense given that on the mobile,
>> interpreting would be quite a bit slower. If you can help me get started, I
>> will try and port 1.9.0-3.
> Please start with the 1.8.x recipe in OE and update our patches accordingly.

Well I will try but I have never been able to get a build to complete in the pure OE environment, 
whereas Mokomakefile for some reason builds fine.

Many of the issues I run into when trying to get the pure OE environment to build have been reported 
  by others and never fixed. Including the one that stumped me, I have mentioned these before in 
other threads with no replies.

And now the site seems to be inaccessible, so I can't read how to create my own 
project and bitbake files.

So for now I'll limp along in mokomakefile and see if I can get 1.8.6 to compile, by hacking the 
1.8.5 recipe in place.

When the OE website comes back up I'll try to learn how to correctly add a new version of a project, 
and submit it.

As Mokomakefile is based on Bitbake and a wrapper around OE. I presume whatever I do to get it to 
build in that environment will be OK to submit.


Jim Morris,

More information about the support mailing list