QTOPIA wifi setup for wpa2

Jim Morris ml at e4net.com
Sun Aug 10 06:33:26 CEST 2008

Ok reflashed the 888 qtopia (the update didn't take properly)

It doesn't crash anymore when I delete an internet profile.

However getting to the properties page for the selected wireless is not working as it says wlan 
pending, and there is no properties menu selection.

Jim Morris wrote:
> Jim Morris wrote:
>> Lorn Potter wrote:
>>> Jim Morris wrote:
>>>> Hi,
>>>> I have been playing with the GUI for setting up wifi in the latest 
>>>> trolltechs Qtopia build.
>>>> It sees my network, but there seems no way to setup wpa2 or enter a 
>>>> password. Am I missing something, or has that not been implemented yet?
>>> It isn't very intuitive.
>>> Once you have done WLAN detection->Options->Add new networks (scans 
>>> for networks) <select the network you want>.
>>> You have to go back into the main internet settings window and select 
>>> Options->Properties->Wireless Encryption->select the network you want 
>>> to connect to. From there you can configure which encryption and 
>>> password/phrase.
>> Thanks I'll give that a try.
>> BTW did you know that qtopia (actually the entire thing) locks solid 
>> (crashes) when I try to delete an internet setting.. I can't even ssh 
>> into the thing via USB to see why it crashed.
>> Internet settings -> click on one of the data networks -> click the 
>> options menu => click delete -> HANG.
> HOLD ON I think my libs are out of sync, I need to do an opkg upgrade I 
> think, if the latest qtopia is expecting 2008.8 libs.
> I'll do opkg upgrade and try again. I was seeing some odd message in the 
> logs about libs and versions.
> The problem stems from the fact I used the script you suggested to 
> upgrade qtopia rather than reflash the rootfs, but this leaves the 
> kernel and libs out of sync.
> I'll report back in a sec...

Jim Morris, http://blog.wolfman.com

More information about the support mailing list