Debian : Touchscreen calibration

Thomas Krahn thomas at
Wed Aug 13 22:10:15 CEST 2008

My experience:

First the calibration for gta02 in the wiki worked fine for me, but after a

apt-get update && apt-get upgrade

the pointer didn't follow the stylo anymore. I needed to overwrite 
/etc/udev/rules.d/50-udev.rules with /etc/udev/udev.rules.dpkg-bak and a 
restart of the X server to get it moving again.

But then the pointer was very far off from the tip of the stylo. 
Obviously the mode how the calculation of the position worked has 
changed with the upgrade. I changed the calibration empirically. The 
following /etc/pointercal parameters worked for me:

0 80000 -8000000 -80500 0 74500000 65536

(On GATA02v5 after the upgrade!)


I also added a short description on how to get GPS working on Debian:

the serial connection is named

instead of 


sparky mat wrote:
> Following the instructions at : 
> , I was 
> able to get touchscreen to work as a mouse. But, the cursor is way off 
> from where I am touching. I am guessing the calibration mentioned 
> there is not accurate anymore? Has anyone managed to get it working on 
> Freerunner?

More information about the support mailing list