[Debian] trying to get bluetooth headset to work

Josh Thompson lists at joshandbianca.net
Wed Dec 3 04:00:36 CET 2008

I still have the buzzing issue with my FR; so, I'm trying really hard to get a 
bluetooth headset to work.

I just ran apt-get upgrade today.  I'm pretty sure my kernel is a debian 
supplied one and not from FSO.  I have fso-frameworkd and 
bluez-audio and bluez-utils 3.36-2.

I've followed the instrunctions at


I modified the BtHeadset.py script to use the freesmartphone API to power 
bluetooth.  The script runs and keeps looping in the loop at the end of the 
script.  However, it seems "headset.Play()" always fails.  At the above URL, 
it says once the script is looping, you should hear static in your headset.  
I never hear this.

I followed the "Command line" portion at the end of this document:


and the Play part always fails with that too.

As another test (and I have no idea if this should really work), I tried using 
the diagram here:


to try to route audio from MIC2 to the bluetooth speaker and audio from the 
bluetooth mic to ROUT1.  Neither of these worked.

I haven't really been able to find anything about what the headset.Play() 
function is supposed to do to know if it failing is the root of my problem.

Running "hcitool con" does show there is a connection to my headset.

Any ideas on how to get this to work?


More information about the support mailing list