GSM no longer registers on GTA02 - how to troubleshoot?

Andy Green andy at
Tue Dec 9 17:33:49 CET 2008

Hash: SHA1

Somebody in the thread at some point said:
| Hi everybody,
| I have been using Freerunner as a daily phone for some months now, and
| yesterday it suddenly stopped registering the GSM network. It was
| working fine in the morning, sending/receiving SMS, making phone
| calls, etc., then in the afternoon suddenly the phone portion was
| completely dead. I restarted qpe (running Om2008.9) a few times, then
| rebooted the phone, pulled out the battery and SIM and reseated
| everything, etc., but got nowhere. When I got home, I reflashed a
| couple of known good kernel/rootfs combinations, but got nowhere. I
| even tried an FSO image, since it uses a different phoneserver, but it
| didn't work either. I put my SIM into my old dumbphone (which is a
| little bit broken, in that it only works on speakerphone) and it was
| able to register with no problems.
| How can I troubleshoot GSM registration to see at what point the
| process is failing? I would hate for this to be a hardware problem,
| but I don't know what to do when reflashing doesn't work.
| I do have another issue, which I don't think is related: my NAND
| u-boot seems to be borked. Whenever I boot the GTA02 without booting
| it from the NOR u-boot, I get a scrambled image on the screen and the
| device is frozen. Often, the scrambled image that appears is whatever
| was in the framebuffer right before powering off. If I boot into NOR
| u-boot, I can boot into the OS fine, but if I just try to turn it on
| without holding down the AUX button or try booting into NAND u-boot, I
| get a freeze. I've tried reflashing u-boot several times, but it
| doesn't help. I download u-boot from and the
| md5 sum of my u-boot image is 40b8f908649f78e7d70358239da96f98. Is
| this a known good image? Why would u-boot fail after reflashing?

Your U-Boot environment can have some issue, that's why the problem
behaviour is so sticky.  You are into trying to get a USB serial
connection on ttyACM0 on your host and meddling from there.

About your main problem not much idea except confirm the SIM still works
on another phone I guess.

- -Andy

Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Fedora -


More information about the support mailing list