Still can't register GSM

danek daniel at
Sat Dec 13 00:47:27 CET 2008

I don't think a user can flash GSM firmware, only OM, due to NDA on the

The GSM firmware is whatever came on the GTA02v5 when I got it. I believe it
is moko10 but can't confirm now because I don't have it with me.

As I said in the original post, it was working fine (well, as fine as a
GTA02 can work) for months, then all of a sudden stopped registering, and
nothing I have done has restored it.

On an unrelated note, I just discovered - very useful for those subscribed in
digest mode or no mail.

Sargun Dhillon wrote:
> Stupid question,
> Have you flashed moko10 gsm firmware?
> On Fri, Dec 12, 2008 at 2:08 PM, Daniel Dadap <daniel at> wrote:
>> I wrote earlier about being unable to register GSM. It happened out of
>> the blue and I still can't register.
>>> Date: Tue, 09 Dec 2008 16:33:49 +0000
>>> From: Andy Green <andy at>
>>> Subject: Re: GSM no longer registers on GTA02 - how to troubleshoot?
>>> Your U-Boot environment can have some issue, that's why the problem
>>> behaviour is so sticky.  You are into trying to get a USB serial
>>> connection on ttyACM0 on your host and meddling from there.
>>> About your main problem not much idea except confirm the SIM still works
>>> on another phone I guess.
>>> - -Andy
>> Yeah, I'm going to try messing around over the USB console, but I'm
>> trying to get GSM to work first.
>> The SIM works fine on my dumbphone which I have been using for the
>> past few days. I've tried two different SIMs, from two different
>> carriers, both of which used to work on my FR, and both of which still
>> work on other phones. I know that the FR can see the SIM because I can
>> read contacts off of it and stored SMS messages. I have reflashed the
>> phone with several images which were all known working. I'm stumped,
>> and I'm worried that it might not be a software problem. (I think FR
>> only has 30 or 60 day warranty and mine is already older.)
>> How much would an out of warranty repair cost, if I have a hardware
>> problem?
>> How can I tell what the FR is trying to do when it tries to register
>> (and fails)? I like to know if it seems to be the antenna, or the
>> Calypso, or something else.
>>> Date: Tue, 9 Dec 2008 12:09:47 -0500
>>> From: Paul <paultsai at>
>>> Subject: Re: GSM no longer registers on GTA02 - how to troubleshoot?
>>> To: "Support for Openmoko Device Owners" <support at>
>>> Message-ID:
>>>        <c31a36600812090909hc71e2cevfdc0feb007c40f88 at>
>>> Content-Type: text/plain; charset=ISO-8859-1
>>> I received the same behavior when I updated to the latest testing
>>> images.
>>> I revered to the old 2008.9 images and things are working again.
>>> --
>>> Paul
>> I tried many different images, all of which used to work fine. None of
>> them can register.
>> Also, does anybody know how I can reply to a message and keep it in
>> the right thread if I don't receive individual messages? (I am
>> subscribed in digest mode.) Is there a web interface where I can reply
>> to a specific message?
>> _______________________________________________
>> support mailing list
>> support at
> _______________________________________________
> support mailing list
> support at

View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list