Still can't register GSM

danek daniel at
Sat Dec 13 14:54:29 CET 2008

William Kenworthy wrote:
> 1. flash moko10 as recommended below - fixes problems with some
> incompatible SIMs.  On my Vodafone 128K, made a huge difference to the
> PIN dialog popping up - not 100% fixed, but made a difference between 1
> in 10, to 1 in 2.
Indeed! It turns out that my phone had moko8 firmware. I don't know how I
managed to miss the fact that OM had released a firmware update that users
could flash. I updated to moko10, but unfortunately, it hasn't had anny

2. try logging in and run "logread" - if you see "ATCHAT: ATF modem
> ready" (something like that anyway) continually being repeated.  Restart
> X (/etc/init.d/xserver-nodm reboot) - give it up to 10 goes or so (then
> try 3 below).  On my phone (even with moko10) it appears to be
> unresponsive to the first reset/commands and just starts repeating the
> above message to the log.  Restarting X gets it to try again.  It doesnt
> do it if you leave it to its own devices.
Indeed, when I had reflashed the first time after the modem stopped working,
restarting X a bunch of times was one of the first things I could think of.
I also tried restarting qpe on the distributions I tried which had Qtopia
middleware. I hadn't tried "logread" though, I will try that now and see
what I can find.

3.  Shut down, remove battery for a few seconds.  Replace battery,
> reboot, go to 2 above if neccesary.
If I had a nickel for every time I did that...

4. Remove any SD card (esp if over 4gb) and retry.
I was already running without SD card for a few days at that point. (I had
flashed back to 2008.9 after playing with FSO Milestone 4,1 for a few days.
When I flashed 2008.9, I had forgotten to disable indexing of the SD card
for Qtopia, so it was acting really slowly as qpe ate my whole CPU to index
my huge folder of OSM maps for TangoGPS. At the time, a colleague was
phoning me every couple of minutes to coordinate something, and I wasn't
near a computer that I could use to change the setting, and I hadn't yet
installed openmoko-terminal2, so I just pulled my SD card out, and hadn't
bothered to put it back in yet by the time I started having the registration

5. Use another phone and set a PIN on the SIM if not set and try again
> (at least one software version wouldnt work if PIN wasnt set :(
That's a good idea. I will try setting a PIN on my dumbphone.

6. Reboot, wait for a few minutes (5?) where nothing is happening and
> run "logread > logread-<current-date>.txt" and post
> logread-<current-date>.txt here for comment.
Will do. I will probably spend much of today, since I'm not working,
troubleshooting this some more.

7. Try 2008.testing in combination with moko10
I will get to it in my rounds of reflashing, believe me. :)

8. file a bug - I would think it most unlikely its a hardware problem
> (other than the known one of incompatible SIMs) - its probably down to
> the software.
Given my experience with the phone, I would normally think it was something
in the software too. I do suspect the hardware, though, unfortunately,

1. It had been working for months as the phone I used every day. I never had
problems with not being able to register the network or random bounces off
the network as others have had. (I have had many other frustrating problems,
but that was never one of them.) It was even working quite well on the
morning of the day that it stopped working... I only noticed that something
was wrong later that day when I tried to make a call, and couldn't.
2. I tried two different SIMs, from two different carriers. My main SIM,
which I had been using daily for months without problems, and another from
another carrier, which I had previously used for a few days for testing.
3. I tried every software distribution I have ever run on the phone (I have
a directory on my laptop with dozens of kernel and rootfs images). I had
NEVER had problems registering with any of them when I was testing them
before, except with FSO before installing the kernel modules. (Why they
aren't part of the rootfs image, I don't know.) All of the images were
flashed and then tried directly, without first restoring any of my data.

Anyway, I will try setting a PIN and I will try inspecting the logs. Thanks
for the suggestions.
View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list