built-in mic broken?

Florian Schmidt schmidt_florian at gmx.de
Sun Dec 14 19:48:50 CET 2008


i think the built-in microphone of my moko died!

i am usually running a customized FSO on my moko, but at sometime in the
last weeks the microphone built into it stopped working. (it was working
fine before)
i have no clue what caused this.

i can make and receive calls, hear the other side but no one can hear me.

this weekend i tried to get it working again. i tried many
alsa-mixer-configurations and everything seems to work as expected
(headset mic, headset speakers, both handset speakers, pcm out ...) except
the built-in microphone (alsa mic2 right?)!

to ensure that it is not a configuration problem i today reflashed my moko
with these distributions (rootfs + matching kernel):


and tried to make a call.

all showing the same problem, no sound from the built in mic to the gsm

(the wired headset works perfectly with e.g. om2008.4, and the built-in
speaker also works...)

now what can i do?

this week i will try to contact my distributor (Golden Delicious
Computers) and ask them how to proceed.

anyone else with such problems?

will someone repair my moko?

always using the wired headset is not really an option. also all my
friends calling me are slowly getting displeased not able to hear me :)


More information about the support mailing list