[FDOM, 2008.9] USB not working after suspend/resume-cycle

Marcos Mezo mmezo at selexco.net
Thu Dec 18 12:16:12 CET 2008

On Thursday 18 December 2008 00:39:42 Konstantin wrote:
> Andy Green wrote:
> > Does it help if you reassert the two host mode things by hand in /sys?
> >
> > http://wiki.openmoko.org/wiki/GTA02_sysfs#USB_Host_.2F_Device
> Thanks for your answer - unfortunately, that doesn't help. After having
> suspended the freerunner for any period of time, it becomes impossible to
> use host mode, even if I switch to device mode and back. After suspending,
> activating host mode and plugging in a usb device results in nothing at
> all, no dmesg output, nothing.
> The only thing that helped was removing and reloading the ohci_hcd module,
> but that obviously only works with a kernel which has this one built as a
> module.

Somebody on some list said that doing an "lsusb" fixed it for him. I've not 
even tried USB host mode myself.


More information about the support mailing list