Debian boot problems...

Darkas andre.knispel at
Sun Dec 28 21:44:25 CET 2008


I recently installed Debian on my Freerunner. The installation worked fine,
I installed it with Qi "support" and of course Qi on my phone (in the NAND).
Then I tried to boot the Freerunner from NAND (pessing and holding power and
then AUX too) but it always boots Qtopia from flash. I also tried to boot
from NOR and boot with Boot from microSD (Fat+ext2), but it gives some
output and returns then to the boot menu (just the information that I think
it could be useful :) ):

Card Type: SD 2.0 SHDC
Manufacturer: 0x03, OEM "SD"
Product Name: "SU04G", revision 8.0
MMC/SD size: 3MiB

reading uImage.bin

** Unable to read "uImage.bin" from mmc 1:1 **
Wrong Image Format for bootm command
ERROR: can't get kernel image!

If I just press the power button until it starts, I get the following

s3c2410_udc: debugfs dir creation failed -19
Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.
Kernel panic - not syncing: VFS: Unable to mount root fs on

Then the led under the AUX button blinks red and the Freerunner hangs and I
have to pull out the battery.

And my bootloaders look like this:

root at om-gta02:~# grep Bootloader /dev/mtdblock1
Qi Bootloader s3c2442 master_a2d11c4dd18c9517

root at om-gta02:~# grep Bootloader /dev/mtdblock0
Neo1973 Bootloader U-Boot 1.3.2-moko12

So, this is all information I have that could be useful to solve the
problem. If there is any additional information needed, just tell me, I'm
not very familiar with the booting process of the Freerunner yet.

Could anyone please help me with my problem? Thanks in advance!
View this message in context:
Sent from the Openmoko Support mailing list archive at

More information about the support mailing list