Debian boot problems...

Joachim Ott jo.omsl at
Mon Dec 29 01:56:23 CET 2008

2008/12/28 Darkas <andre.knispel at>

> I recently installed Debian on my Freerunner. The installation worked fine,
> I installed it with Qi "support" and of course Qi on my phone (in the
> NAND).
> Then I tried to boot the Freerunner from NAND (pessing and holding power
> and
> then AUX too) but it always boots Qtopia from flash. I also tried to boot
> from NOR and boot with Boot from microSD (Fat+ext2), but it gives some
> output and returns then to the boot menu (just the information that I think
> it could be useful :) ):
> Card Type: SD 2.0 SHDC
> Manufacturer: 0x03, OEM "SD"
> Product Name: "SU04G", revision 8.0
> ...
> MMC/SD size: 3MiB
> reading uImage.bin
> ** Unable to read "uImage.bin" from mmc 1:1 **
> Wrong Image Format for bootm command
> ERROR: can't get kernel image!

Can you check (from Qtopia), that the first partition on the SD is really
FAT and that the uImage.bin is really there. A "ls -lR" of that partition
would help.
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the support mailing list