not charging...

Dirk Bergstrom openmoko at
Wed Jul 16 08:59:07 CEST 2008

lapubell wrote:
> i don't know what the problem is, but my freerunner is not charging via usb. 
> I got it today, and i'm wondering if it is DOA?  the phone first showed a
> charging icon in the top right when plugged in, but now it will not change
> off of the battery icon, which is slowly depleating...

I noticed that my Freerunner wasn't charging today, even though it was 
plugged into the charger.  It worked yesterday, so I figured it might be 
an intermittent thing.

I tried unplugging the cable and plugging it back in.  Then I unplugged 
the charger from the wall and plugged it back in, which did the trick. 
Just now I tried unplugging and replugging the charger usb connector a 
few times, and got varying results.  Sometimes the usb icon in the 
toolbar would show up, sometimes not. Similarly, the "charging" icon 
sometimes showed up (the battery is fully charged).  At one point, I 
pulled the cable out, and the charging icon came on.  Also, the speaker 
makes its 'click' noise when you plug in the cable, and when you remove 
it.  Once I plugged in the cable, and got two clicks very close 
together, and the usb icon blinked briefly.

I suspect that the software is easily confused.  Try messing about with 
the cable.


More information about the support mailing list