SSH into Freerunner

Colan Lash colanlash at
Thu Jul 17 06:54:18 CEST 2008

Based on reading the wiki, it seems as though it does not like it if
your LAN is in the same range (i.e. also uses 192.168.0.*)

This is for Windows, but I think the same might apply for Linux as well:
I read here
that you should disconnect your host from your LAN, so that its DHCP
server does not interfere.  With that you should be able to ssh into
the FreeRunner.

Once you do this, you can change the /etc/network/interfaces file on
the FreeRunner (I think you have to use the vi editor).
In the file, set for usb0


Or you can set number to whatever you want.


On Wed, Jul 16, 2008 at 8:40 PM, shawn sullivan <shelbydz at> wrote:
> Correct. And when I run ifconfig afterwards I get:
> usb0      Link encap:Ethernet  HWaddr ee:8e:94:93:61:96
>           inet addr:  Bcast:  Mask:
>           inet6 addr: fe80::ec8e:94ff:fe93:6196/64 Scope:Link
>           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
>           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>           TX packets:15 errors:0 dropped:0 overruns:0 carrier:0
>           collisions:0 txqueuelen:1000
>           RX bytes:0 (0.0 B)  TX bytes:2733 (2.6 KB)
> Steven ** wrote:
>> I assume the ifconfig command doesn't give any errors when you run it.
>>  I know I had to run it with sudo for it to work.
>> -Steven
>> On Wed, Jul 16, 2008 at 9:30 PM, shawn sullivan <shelbydz at> wrote:
>>> Thanks Steven. I've actually tried both variations with the same
>>> results. I thought maybe my system was getting confused w/ the
>>> Steven ** wrote:
>>>> Not sure if it makes a difference, but everyone else uses
>>>> and  You've got a 1 instead of a 0.
>>>> -Steven
>>>> On Wed, Jul 16, 2008 at 9:20 PM, shawn sullivan <shelbydz at> wrote:
>>>>> I've been unable to SSH into my phone. I did:
>>>>> ifconfig usb0 netmask
>>>>> but when I do:
>>>>> ssh root at
>>>>> it can't find the host. i've tried disabling the firewall; no dice.
>>>>> Here's my routing table:
>>>>> Kernel IP routing table
>>>>> Destination     Gateway         Genmask         Flags   MSS Window  irtt
>>>>> Iface
>>>>>     *        U         0 0          0
>>>>> eth0
>>>>> link-local      *          U         0 0          0
>>>>> eth0
>>>>> default         dslmodem.domain         UG        0 0          0
>>>>> eth0
>>>>> It appears that there is no route to the USB port, but I'm not sure how
>>>>> to enable that. Can someone help me out? I'm running Ubuntu. I did
>>>>> verify that the phone is on USB0, but I cannot get any results when I
>>>>> ping the IP address.
>>>>> thx
>>>>> . . .shawn
> _______________________________________________
> support mailing list
> support at

More information about the support mailing list