Thomas B. tommy.b at gmx.net
Tue Jul 22 22:15:32 CEST 2008

On Tue, Jul 22, 2008 at 09:05:29PM +0200, Joerg Lippmann wrote:
> Hi!
> Am Dienstag 22 Juli 2008 schrieb Dave Clark:
> > Why not put Qtopia on the SD card, and 2007.2 in the main memory? It's
> > fairly easy to dual-boot...
> I tried that for the last 2 hours, using the wiki howto 
> (http://wiki.openmoko.org/wiki/Qtopia_on_FreeRunner). It went quite smoothly. 
> up to the point where the qtopia-kernel panics when he is not able to mount 
> the root-Filesystem. I tried this with ext2 and ext3, same error:
> [...]
> VFS: Cannot open root device "mmcblk0p2" or unknown-block(179,2)
> [...]
> Any idea how to fix that would be great!

I think the kernel delivered with Qtopia doesn't have ext2 support built
in (only as a module, which is not available without rootfs), and it
doesn't work with ext3 either because U-Boot passes "rootfstype=ext2" to
the kernel as a commandline option.

You can try a recent stable kernel (from Openmoko), I think a few days
ago a patch was checked in that enables ext2 support. So a recent stable
kernel should be able to boot from an ext2 partition.

Alternatively, you can try to persuade U-Boot to tell the kernel to use
ext3. I described how I did that here (didn't have time to put it in the
wiki yet... and I don't know if it's relevant any more, as booting from
ext2 hopefully works now):


Thomas B.

More information about the support mailing list