Joerg Lippmann j at donalbain.de
Tue Jul 22 23:15:11 CEST 2008

Am Dienstag 22 Juli 2008 schrieb Thomas B.:

> > > Why not put Qtopia on the SD card, and 2007.2 in the main memory? It's
> > > fairly easy to dual-boot...
> >
> > I tried this with ext2 and ext3, same
> > error:
> >
> > VFS: Cannot open root device "mmcblk0p2" or unknown-block(179,2)

> I think the kernel delivered with Qtopia doesn't have ext2 support built
> in (only as a module, which is not available without rootfs), and it
> doesn't work with ext3 either because U-Boot passes "rootfstype=ext2" to
> the kernel as a commandline option.

That actually makes sense :-)

> You can try a recent stable kernel (from Openmoko), I think a few days
> ago a patch was checked in that enables ext2 support. So a recent stable
> kernel should be able to boot from an ext2 partition.

Yeah, I tried the most recent kernel I could get my hands on and it works now! 

Many thanks!
Jörg at home

More information about the support mailing list