mkfs.vfat on 2007.02

Thomas B. tommy.b at
Sat Jul 26 17:31:42 CEST 2008

On Sat, Jul 26, 2008 at 04:09:53PM +0200, arne anka wrote:
> > So, hypothetically, only one partition needs to be made.  A separate boot
> > partition is no longer necessary, right?
> well, i tried yesterday to install qtopia to an sd card.
> while using one single partition ext3 and simply unpacking the tar  
> (complete filesystem, not the jffs2/img tar from qtopia) the fr was unable  
> to boot from the sd card (the error message disappears far to early to be  
> able to jot it down).
> i switched to vfat boot partition and ext2 for the filesystem and  
> everytheng was fine -- except taht you nedd to put the uImage.bin directly  
> into the boot partition, not a boot/ directory!
> poses the question which u-boot it is that makes the fr booting from an  
> ext3 sd card.

I got it to work with the most recent U-Boot [1]. Haven't tried it with
older versions, so I don't know whether it is needed.

But, you not only need a suitable U-Boot version, you also have to
adjust your U-Boot environment. The "Boot from SD" menu entry in the
default U-Boot environment that shipped with my Freerunner explicitly
told U-Boot to load the kernel from the first partition of the SD with
FAT filesystem and rootfs from second partition with ext2 filesystem.
You have to adjust this to your partition setup (e.g., replace "fatload"
command with "ext2load" command). See [2] for hints how to do that.


[1] u-boot-gta02v5-1.3.1+gitr6+ba029a1426bfca169572bf80d50a8b190a6b0e19-r0.bin

More information about the support mailing list