Next step on un-bricked FreeRunner

Thomas B. tommy.b at
Mon Jul 28 02:42:39 CEST 2008

On Sun, Jul 27, 2008 at 04:45:33PM -0700, MR BROWN wrote:
> I was unable to use my FR until today meaning I could only access my boot menu
> before.  How and why I was able to do that is a mystery to me.  I had to
> literally go thru every command and flash every thing.  Nothing worked except a
> couple of .bin flashes that ended the download in progress with a notice on my
> phone screen saying, "End of write Exceeds Partition end"  Download Error-110. 
> First of all does anybody know what that means?  Secondly, I guess I cannot
> complain since I'm at least able to make and recieve calls now.

Maybe you tried to flash the wrong partition? In the Freerunner's
internal flash there's a small partition for the kernel (uImage*.bin)
and a large partition for the rootfs image (*.jffs2). You can select
which partition to flash with the "-a" parameter of dfu-util, e.g. "-a
kernel" oder "-a rootfs".

> Now my question is how do I gain access to my phone's Terminal in a realistic
> manner.  I can get there from the phone But, There is no slash..  ie.  /,  That
> makes it very hard to enter any code.  Second, there was a point in my trouble
> shooting that the terminal root system came up on my linux system as
> root at om-gta02.  That would be a great place to program the phone from but how
> do I get there from my host system?  I will keep learning linux from the books
> I have but I have not found the way to get there yet.  Does anyone know the
> short cut code?  Now the only way I can start my phone is to go through the
> boot menu and enter the boot option.

Have you tried to connect
to your Freerunner?

> To finish, I've looked at the downloads for Qtopia in the hopes of flashing a
> keyboard that is realistically usable.  There are many downloads there
> including one the requires 2.1M.  My question also concerns the original error
> message -110 above.  It is my understanding that if I did not have enough room
> to flash 1.7M and the largest partition on the phone is 2M that I could not use
> a file that is even larger.  Does that mean I need to use my SD card for the
> download of Qtopia?

Do you mean the application downloads at I don't know how
those are meant to be installed, but certainly not by flashing with
dfu-util. Flashing an image file with dfu-util overwrites anything that
has been in that partition before. It's similar to formatting the hard
drive of your PC and reinstalling the operating system. To install
single applications, you have to use other methods (depending on which
distribution you are using, e.g. Qtopia or OM2007.2).


More information about the support mailing list